Re: [Amel Yacht Owners] Link 10


Erick MEJEAN <maramu@...>
 

Hi Philippe
Dont bother getting this instrument repared. Not worth the money; Get the Mastervolt Ampmeter instead which is what I did . Pas de comparaison....... It came actually first in a survey made by Voiles et Voiliers
Best Regards
Erick MEJEAN


----Original Message Follows----
From: "baligand2001" <baligand@hotmail.com>
Reply-To: amelyachtowners@yahoogroups.com
To: amelyachtowners@yahoogroups.com
Subject: [Amel Yacht Owners] Link 10
Date: Thu, 17 Jun 2004 17:24:22 -0000

Hello to all,

I'm facing problems with the ampmeter functions of the
Link 10 and wonder if any of you has already faced and solve the
same. My link 10 still provide a proper voltage measure but all amps
indications have suddenly quit. It no longer provides either the
immediate amps consumption (A) which is stuck to a permanently
displayed number 509,or total amps consumed (AH) which actually keep
increasing as opposed to the reverse and the related T function
which is stuck to 100 %. I checked the fuses which are all right,
disconnected the batteries to shut off the Link 10 and then switch
it on again but all to no avail.
I guess the Link 10 itself must be the culprit. Has
someone already taken the step of removing the Link 10 to bring it
in for repair ?
Amel have kindly mailed me a copy of the manual but not
offered a solution.

Thank you.

Philippe GUYOT
Baligand SM 245

_________________________________________________________________
Keep track of Singapore & Malaysia stock prices. http://www.msn.com.sg/money/

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.