Re: [Amel] Re: Onan


Peter Forbes
 

How amusing - I have just printed this gold dust and put in in my on board data file!

Thank you

Amel 54 # 035
In modification Go├žek Turkey.

Peter Forbes

07836 209730
ppsforbes@...

On 28 Jun 2013, at 12:46, Kent Robertson <karkauai@...> wrote:

As usual, Gary...YOU DA MAN!!!
I'm going to print this and put it in my on-board folder.
Kent

________________________________
From: Richard03801 <richard03801@...>
To: "amelyachtowners@..." <amelyachtowners@...>
Sent: Friday, June 28, 2013 7:01 AM
Subject: Re: [Amel] Re: Onan



Hi Gary that was a very nice way to troubleshooting the onan good job

Regards
Richard Piller

Cell 603 767 5330

On Jun 28, 2013, at 1:02, amelliahona <no_reply@...> wrote:

Hi Trevor:

Perhaps you have already solved your problem but let me seek some clarification on your problem. Do you have the shop manual for your genet?

1. I am confused from your post whether this is a problem with the engine cranking or whether this is a problem with the engine running.

a) If the engine suddenly stops, in my experience, this is usually due to one the several sensors on the engine (sea water temp over heat, low oil pressure, etc) telling the engine to shut down. You need to methodically work through each sensor (I don't have my shop manual here but I think there are at least 6 different sensors). They may actually be sensing a fault condition or there may be a faulty sensor, you will have to determine what is the case and repair accordingly. The sensors are mostly either normally open or normally closed switches and can be tested using a multi-meter.

b) If the engine won't crank (turn over as in trying to start it) then you have one of four problems;NOTE: THESE ENGINES HAVE TWO STARTER MOTOR SOLENOIDS (aka CONTACTORS). There is one on the + side and one on the - or ground side. Both solenoids have to work for the starter motor to work crank the engine.

1- a faulty positive side (12 VDC) contactor, check to see if you have 12 volts on the supply side of this contractor, then see if you have 12 volts on the output side of the contractor while someone tries to crank the motor with the start switch, if you have 12 volts in and 12 volts out when activated then this contactor is ok next ,
2- a faulty negative or earth side contractor (starter to ground on the tray). This contactor is mounted below the starter motor and is somewhat out of sight unless you bend way over. If you bypass this contactor you will NOT harm your engine. If bypassing this contactor allows the engine to crank when the start switch is activated then you either have a bad ground or a faulty ground side contactor.
3- a faulty starter motor, If you can measure 12 volts on the supply to the starter motor with your multimeter when the start switch is activated and you have a known good ground side contactor and known good positive side contactor, yet the motor won't crank, then your starter motor is faulty. Just to verify this you can remove the starter motor and take it to a shop to have it tested and/or repaired.
4- a faulty starter switch. If you don't see 12 volts on the control line to the contractors (both + and - side contractors) when the start switch is activated, then you probably have a faulty starter switch.

Once again, cranking (the engine being turned over by the starter motor) is a whole different problem from running. If you have already solved this, please let us know what you found. If not, give us some more details and perhaps we can add some more suggestions.

Best of luck,

Gary Silver
s/v Liahona
Amel SM2000 Hull #335
on the hard at Jolly Harbor, Antigua

--- In amelyachtowners@..., "seafeverofcuan" <seafeverofcuan@...> wrote:

Dear All,
my generator stopped dead while running a few days ago. No flashing lights. It cranked a couple of times then silence
I have checked the raw water, fresh water,systems, changed the fuel pump, a suspect earth strap from the solenoid to the tray . I have 12.7 volts at the solenoid if I short the terminals the engine will crank, but I don't want to let in run incase of further damage.
I have swopped over the relays for the starter under the white casing lid, but nothing all I get is the flashing green light at the start switch for a few seconds, I can feel the new fuel pimp working but no engine cranking.
The genset had a new rotor,stator and control panel last October at 1000 hours after burning out.
If anyone can shed some light I would be most grateful. I am in Mazatlan Mexico where the local service companies are willing but have no knowledge or access to Onan.
Many thanks.
Trevor

Seafever of Cuan
No 425
[Non-text portions of this message have been removed]

[Non-text portions of this message have been removed]


[Non-text portions of this message have been removed]

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.