Re: Onan

Jim Anderson
 

I agree too: excellent troubleshooting instructions for the Onan MDKAV, Gary, thank you!

May I add one more thing? Not because I'm an expert by any means but just because this happened to me. My problem was that the generator thought it had a problem, but it didn't. It would not allow itself to be started or run even though nothing was wrong with it. The problem was the "PCB Control Board, (new) part #327-1533.

Each time I tried to start the generator it would crank but not run. Then it gave the fault code for insufficient raw-water cooling.(I'm not aboard now but 5 flashes of the light if I remember correctly.) The raw water flow sensor was good and I had just replaced the impeller. The generator even pumped plenty of water out of the exhaust while cranking so I knew that what the generator was "thinking" was wrong and determined the problem was the PCB Control board. When I went to order a new one I was told that the original part number had been superseded by a new part, part #327-1533. I unplugged the old board, pluged in the new one and it ran perfectly. I should mention that it took quite a while to get to the circuit board. Not difficult but allot of screws to remove.

I hope no one else has this problem but since Onan discontinued the old part and superseded it with a new one it makes me think that maybe the old one had problems, as I experienced.

Best,

Jim
SM384 Sirena Azul

On Jun 28, 2013, at 1:02, amelliahona <no_reply@...> wrote:

Hi Trevor:

Perhaps you have already solved your problem but let me seek some clarification on your problem. Do you have the shop manual for your genet?

1. I am confused from your post whether this is a problem with the engine cranking or whether this is a problem with the engine running.

a) If the engine suddenly stops, in my experience, this is usually due to one the several sensors on the engine (sea water temp over heat, low oil pressure, etc) telling the engine to shut down. You need to methodically work through each sensor (I don't have my shop manual here but I think there are at least 6 different sensors). They may actually be sensing a fault condition or there may be a faulty sensor, you will have to determine what is the case and repair accordingly. The sensors are mostly either normally open or normally closed switches and can be tested using a multi-meter.

b) If the engine won't crank (turn over as in trying to start it) then you have one of four problems;NOTE: THESE ENGINES HAVE TWO STARTER MOTOR SOLENOIDS (aka CONTACTORS). There is one on the + side and one on the - or ground side. Both solenoids have to work for the starter motor to work crank the engine.

1- a faulty positive side (12 VDC) contactor, check to see if you have 12 volts on the supply side of this contractor, then see if you have 12 volts on the output side of the contractor while someone tries to crank the motor with the start switch, if you have 12 volts in and 12 volts out when activated then this contactor is ok next ,
2- a faulty negative or earth side contractor (starter to ground on the tray). This contactor is mounted below the starter motor and is somewhat out of sight unless you bend way over. If you bypass this contactor you will NOT harm your engine. If bypassing this contactor allows the engine to crank when the start switch is activated then you either have a bad ground or a faulty ground side contactor.
3- a faulty starter motor, If you can measure 12 volts on the supply to the starter motor with your multimeter when the start switch is activated and you have a known good ground side contactor and known good positive side contactor, yet the motor won't crank, then your starter motor is faulty. Just to verify this you can remove the starter motor and take it to a shop to have it tested and/or repaired.
4- a faulty starter switch. If you don't see 12 volts on the control line to the contractors (both + and - side contractors) when the start switch is activated, then you probably have a faulty starter switch.

Once again, cranking (the engine being turned over by the starter motor) is a whole different problem from running. If you have already solved this, please let us know what you found. If not, give us some more details and perhaps we can add some more suggestions.

Best of luck,

Gary Silver
s/v Liahona
Amel SM2000 Hull #335
on the hard at Jolly Harbor, Antigua

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.