Re: [Amel Yacht Owners] Seeking Volvo TMD22 and Brunton Autoprop information and advice

Giovanni TESTA
 

Hi, I had same problem with yanmar 100 motoring between Tonga and NZ.
On yanmar i pushed down the upper pump on engine filter and rpm grew up again, so the problem was the dirty main filter.
I replaced this filter and rpm was again ok .
First always change filters...if you didn't yet.
All the best
Gianni
Sv Eutikia sm 428


Il giorno 14/feb/2014, alle ore 16:40, <atioceania@...> ha scritto:

 

Hi. We have a 1997 SM, hull 202, with a Volvo TMD22B and Brunton Autoprop that under load will only reach 2300 RPM at best and suboptimal boat speed. The Volvo readily spins up to higher RPMs in neutral with just a bit of white smoke, "sounds good" and doesn't burn any oil; while under load, we reach 2300 at half throttle and then can go no higher no matter how much more fuel we add. A couple of non-Amel mechanics suggest the Autoprop is the trouble, although it seems to fold fine manually when I dive it, and we see no significant difference between it being just cleaned or not.

Does anyone have pitch and setting recommendations for this prop, which I think is an H6, with the Volvo engine on an SM, or any thoughts and advice? Also, who might we talk to to service the prop? We are currently in St Pete FL, with hopes to solve the power problem and be cruising south in the very near future.
 
Thank you.
Scott and DIane

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.