Re: [Amel Yacht Owners] LOW ENGINE RPMS ON YANMAR 75


Germain Jean-Pierre <jgermain@...>
 

Hello Ben,

I have a Volvo TDM 22 but diesels are diesels…

I encountered these symptoms on another boat… badly crusted propeller…

Other cause might be a faulty turbocharger.  Generally, we tend to baby our engines and this is not good.  I try to run at 80% or more power for 1 hour out of every 24 hrs of engine time.

Third possibility = a collapsed air filter.  BTDT.

Good luck.. at least the trouble shooting should be easy.


Jean-Pierre Germain,
SY Eleuthera, Amel Super Maramu 007
Porto Turistico Marina di Ragusa, Pontoon M15,
97100 Ragusa, Sicily, Italy
+44 7551 211 511
sy.eleuthera@...


On 4 Dec 2015, at 17:09, joedoakes66@... [amelyachtowners] <amelyachtowners@...> wrote:

 

I bought my SM in Feb 2015  and there are still many systems I need to better understand.  Most perplexing is I have seen declining engine RPMs since original survey.  Originally boat produced about 3100 RPMs (Yanmar manual says 3600/3800 tops - but I do know Autoprop may limit that number)  but has since declined to 1800.  Not sure why as engine seems to run fine - easy start, no smoke, no roughness at any RPM.  Racor and engine filters are new.  Manual shut off valve in passageway  is wide open (it actually will not shut off motor... but that's another issue).   I do have an Autoprop which was serviced well over a year ago - but not sure - by previous owner. Only other engine oddity as it runs very cold - never over 130F.   Boat has been in the water now for a little over a year with not much motor use.  Any and all suggestions would be welcome. 


Ben Driver

SM #347

La Bella Vita



Posted by: joedoakes66@...
Reply via web post Reply to sender Reply to group Start a New Topic Messages in this topic (1)


Join main@AmelYachtOwners.groups.io to automatically receive all group messages.