Re: [Amel Yacht Owners] Found the problem with my Onan


Danny and Yvonne SIMMS
 

Well done Eric. How often it is the simple answer
Danny
SM 299 ocean pearl

Sent from my Vodafone Smart

On Oct 25, 2016 4:23 PM, "'sailormon' kimberlite@... [amelyachtowners]" <amelyachtowners@...> wrote:
 

My MDKAV had numerous fault signals.

My genset would run for 30 seconds and stop.

First low oil pressure—changed sender—

Now new fault code- no fuel- changed fuel pump-

Another fault defective water temp sender- changed sender

then the dreaded fault 13- change the PCB board had a spare.

Same problem and still code 13.

That stumped even the Onan factory.

The genset was also putting out 53 volts.

 

Having knowledge of the isolated ground on my Yanmar after completely rewiring the engine, I decided the problem was with the isolated ground and the PCB board was not properly connected to the dc negative  from the battery and getting confused as to what to do.

 

I started at the battery cable and cleaned all of the connections and tested the generator  as I cleaned and used corrosion x and tightened the connection..

Finally there was only one connection- the braided ground strap that went to the PCB board.

I removed the screw holding it on to the board, cleaned paint off of the board where the ground strap connects to the board and noticed that the screw which held the strap in place was slightly corroded. I cleaned it up added corrosion x and PROBLEM SOLVED.

 

Fair Winds\

Eric

Kimberlite Amel Super Maramu #376

 

 

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.