Re: [Amel Yacht Owners] Frigoboat two speed fan not working


Mohammad Shirloo
 

Hi Duane;
 
I'm not sure which model of the frigoboat you have. We had a similar issue a few days ago on one of our refrigerators. Ours is an FM W 50F model with variable speed compressor and water cooled. On ours, the compressors would continually start and stop after about 30 seconds. The following was the steps that we took to diagnose the problem:
 
  1. Check to see if the compressor is running. Keep in mind that the compressors are extremely quiet and you must physically put your hand on the compressor to know if it is running.
  2. If the compressor is not running or starts and then stops, you need to make sure that you have steady voltage at the power terminals of the compressor. To do this you must use an analog voltmeter (digital ones may be too slow) and attach it to the power terminals on DC volt setting. You have to monitor the voltage as the compressor is running and when it stops. If the voltage is not steady or drops below 21 volts, then you either have an issue with the batteries or more likely, a loose connection somewhere from the batteries or panel to the compressor.
  3. If the power is steady, on ours, the compressor control board has an output that you can connect an old style LED (with anode and cathode) and when the compressor stops, it will give a code from 1 to 5 with the number of blinks of the LED. In our case it was 3 blinks which once the voltage issue was ruled out, meant that the outside temperature was too high and the compressor RPMs needed to be reduced. After reducing the RPMs from 3500 (max) to 2000 (min) the issue was resolved. The lower RPMs means that it will just take a bit longer to get down to the temperature set by the thermostat.
If you can provide further details once you have checked out the above, then I may be able to provide additional information.
 
Mohammad and Aty
Amel 54 #099
B&B Kokomo
 


From: amelyachtowners@... [mailto:amelyachtowners@...]
Sent: Thursday, July 13, 2017 9:59 AM
To: amelyachtowners@...
Subject: [Amel Yacht Owners] Frigoboat two speed fan not working

 

We've been having higher temps in the Frigoboat refrigerator recently, over 50 degrees F.  

We have already pulled the unit out and cleaned the heat exchanger, and; made sure that all air supply spots are clear; and are now rearranging things inside to ensure interior air flow.  At first that seemed to remedy the situation, but now we're back to higher temps (just a few weeks in between).


My infrared thermometer has 32 deg. F at the coldplate so that doesn't seem to be the issue.


I'm going to order a new thermostat and see if that helps, is there anything else I should check?


While checking on these things, I've found the two speed fan is only working on one speed.  I know it worked in the past.  Is there a fan capacitor that might be the issue?


Thanks!

Duane

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.