Re: Bad Salt Water Manifold


patrick.naegels <patrick.naegels@...>
 

Hi Eric,

we have the same, but our salt-water manifold is still working. We
just see that black paint is rotted with small white points, and
water drops some time at main connection.

It's like that for 3 years, I really wonder why. As you I tough to
electrolysis effect, but this metal part is connected to earth wire.

So, for 3 years, we have on board a new manifold bought by Amel, just
in case ...

But I decide to replace this part before our new blue water crossing.

Patrick - Caramel - SM2000 # 329


°°°°°°°°°°°°°°°°°°°°°°°°°°°°°°
--- In amelyachtowners@yahoogroups.com, "eric freedman"
<kimberlite@...> wrote:

Has anyone had problems with the salt-water manifold rotting out?
This is the manifold that connects to the electric head pumps, the
watermaker, the anchor wash, and the A/c pump via the sea strainer.

Last week I noticed a small drip from the manifold. I touched it
and
my finger went right through the A/C tap on the manifold. When I
removed the manifold, the A/C tap looked like Swiss cheese. I had
to
saw off the tap and put a hose and clamps over it to temporarily
use
the manifold. When I tried to put the manifold back, it snapped
off.
It appears that the factory soldered a BRASS pipe nipple to the end
of
the copper manifold.
This caused electrolysis and the manifold to fail at the junction
where it screws into the ball valve. I am having a new manifold
made
out of stainless in St Martin. Has anyone else seen such a problem?
Fair Winds,
Eric
Amel Super Maramu #376 Kimberlite

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.