Re: [Amel Yacht Owners] Leece Neville 175 A 24v alternator


Danny and Yvonne SIMMS
 

Hi Nick,

I agree with Bill Rouse. The exiteation circuit will be faulty. I have seen just these symptoms across a number of applications over many years. 

Regards

Danny

SM 299 Ocean Pearl

Mangonui

New Zealand

On 26 January 2018 at 03:06 "'Bill & Judy Rouse' yahoogroups@... [amelyachtowners]" <amelyachtowners@...> wrote:

 

 

Nick,

I don't know the ratio of RPM ftom the alternator to the engine, but as I recall it, I would guess about 3:1. If it is 3:1 the alternator would turn at 1800 when the engine is at 600.

Regardless of the ratio, I believe yours should excite when the engine starts. I had that same alternator for 11 years. My engine idled at about 600 RPM. The alternator would excite as soon as the engine started. The one time that it didn't, I had an alarm and red light on the 24 Volt panel. My issue was a loose wire connection on the alternator excite relay, which I described in an earlier email.

BTW, the alternator would not put out much amperage until the engine RPM was more than about 1400.

I hope this helps you and you get it resolved.

Best,

CW Bill Rouse
Admiral, Texas Navy
Commander Emeritus
Amel School www.amelschool.com
720 Winnie St
Galveston Island, TX 77550
+1(832) 380-4970

On Jan 25, 2018 07:38, "sangaris@... [amelyachtowners]" <amelyachtowners@...> wrote:
 

Nick,

The spec sheet on that alternator says the cut-in RPM is 2000 (that's the alternator's rpm, which is faster than the engine's in proportion to pulley size), so it sounds like all is normal. You don't say if it works fine after it cuts in, but if so it sounds like your alternator is working as it should. Was there some new or different odd behavior that prompted your question and makes you suspect there is a problem?
Cheers, Craig Briggs, SN#68 (Btw, on my Perkins factory standard alternator there's a timing circuit that delays cut-in to avoid presenting a high load to the engine on starting.)



---In amelyachtowners@yahoogroups.com, <yahoogroups@....> wrote :

Nick

Yes, I believe any alternator will self-excite at higher revs.

One side of the relay has 12VDVC input when the engine start switch is turned to ON. The other side of the relay switches ON 24VDC to excite the alternator.

It is likely a loose or dirty connection on the relay.

Some Amels had the red warning light for the alternator wired in series with the excite circuit, and if that bulb were burned-out, the alternator will not excite. To be on the safe side, check that bulb, which on a SM is located on the bottom left of the 24 Volt panel. 


Best,

CW Bill Rouse
Admiral, Texas Navy
Commander Emeritus
Amel School www.amelschool.com
720 Winnie St
Galveston Island, TX 77550
+1(832) 380-4970

On Jan 24, 2018 12:49, "kwzy6vgkpvtfohjddjsrotobzwf2pjeafjwalhur@... [amelyachtowners]" <amelyachtowners@yahoogroups.com> wrote:
 

Hi Bill,


The boat is in Antigua, but I am in the UK for the moment. So you suspect that the excitation circuit needs to be checked. If this is the case I guess it self excites at the higher rpm. Would you agree?

Nick
 

 

 

 


 

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.