Re: [Amel Yacht Owners] Victron Centaur 24/60 [1 Attachment]


Danny and Yvonne SIMMS
 

Hi Bill, what was the total amp load.I wince when I read of the load some people put on the system. If it was high and something more started up it could have been a simple over load. Other than that it could be a failure in the hot water element if that was turned on. Couple of simple possibilities.

Regards

Danny

SM 299 Ocean Pearl

On 30 July 2018 at 01:43 "william_maffei@... [amelyachtowners]" <amelyachtowners@...> wrote:

 
[Attachment(s) from william_maffei@... [amelyachtowners] included below]

 

Hey everyone -


Went out for a beautiful day yesterday. Everything was perfect until I plugged back into the dock and flipped the charger on. About a minute after there was a loud "pop" and a plume of white smoke that came from the engine room. Upon further investigation I found that the charger blew. (See picture in mark up). All is good and again I came to respect the redundancies on this boat even more. Problem temporarily solved by switching on the heart charger located in the aft cabin. (Usually I only use this charger as a supplement with my primary (Victron Centaur 24/60 while on generator power) It looks like a resister blew and the charger is less than 2 years old. Can anyone chime in on a  possible reason beside faulty equipment? Voltages all check out at post and plug end. The boat did a good job protecting itself and popped the breaker.  Just looking for some additional comments. Many thanks. 


Bill Maffei

Its all Good

SM #195

 


 


 

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.