Re: [Amel Yacht Owners] resurrecting an old dessalator


Ryan Meador
 

Hi Kent,

Thank you for the data point.  It seems likely we have the same setup.  I believe my membranes are 20", though I haven't measured them.

Ryan and Kelly
SM 233 Iteration
Boston, MA, USA



On Mon, Aug 6, 2018 at 10:57 PM Kent Robertson karkauai@... [amelyachtowners] <amelyachtowners@...> wrote:
 

Hi Ryan,
I have SM 243, she has a 24V 60 L/H Desallator.  I'm not aboard now, but it sounds like that's what you have.  Two 20" membranes?
Kent


From: "Ryan Meador ryan.d.meador@... [amelyachtowners]" <amelyachtowners@...>
To: amelyachtowners@...
Sent: Wednesday, July 25, 2018 11:15 PM
Subject: [Amel Yacht Owners] resurrecting an old dessalator [1 Attachment]

 
[Attachment(s) from Ryan Meador included below]
Hi all,

I'm unsure of which model Dessalator is installed on my boat.  I've attached a photo..  The info on the label on the motor reads:

Amel
No 830042
Type MBT1141L
29V60l/h9848

It appears this is a 24V-only unit.  Is this typical?  I haven't had luck searching the mailing list archives for more info. I think there is something wrong with Yahoo right now..  Can anyone identify this model?

This unit has 13 hours on it.  That is not a typo.  The previous owner said he used it a couple times when he first got the boat and then never again.  I do not know if it was pickled at that time, nor if it has been flushed in the interim.  Can anyone offer advice on what I should do before I try turning it on?  I know I'll need to replace the membranes before I use it, but I just want to see if everything else works or if it needs a more serious overhaul.

Thanks,
Ryan and Kelly
SM 233 Iteration
Boston, MA, USA



Join main@AmelYachtOwners.groups.io to automatically receive all group messages.