Re: Eno Stove Electronic Ignitor


 

Dan,

CorrosionX. Enough said.

Best,

Bill Rouse
720 Winnie St.
Galveston, Texas 77550
832-380-4970



On Mon, Apr 15, 2019 at 5:18 PM Dan Carlson <carlsdan61@...> wrote:

Thanks Bill,  It turns out that it was just poor contacts with the battery.   The battery was the first thing that I checked, and then I also tried to check the contact in the battery case, but it was in fact delivering too low of a voltage due to low contact.  Some dielectric grease on the ends of the battery solved the problem.   When I get back the boat I will take a look for the spare.   I saw all of your clear notations on the different wires, so I knew that you had done some trouble shooting in there at some time. 

 

Best regards,   Dan

 

From: main@AmelYachtOwners.groups.io <main@AmelYachtOwners.groups.io> On Behalf Of CW Bill Rouse
Sent: Monday, April 15, 2019 2:36 PM
To: main@amelyachtowners.groups.io
Subject: Re: [AmelYachtOwners] Eno Stove Electronic Ignitor

 

Dan,

 

I think that you have a spare. When the first one died, I remember I bought 2. I also relocated it to behind the stove to be able to replace easily. Look behind the stove and find a spare that looks like it. I believe I found ignitors at https://www.espares.co.uk

 

Best,

 

Bill Rouse

720 Winnie St.

Galveston, Texas 77550

832-380-4970

 

 

On Mon, Apr 15, 2019 at 10:56 AM Dan Carlson <carlsdan61@...> wrote:

Hello all,. I have the original ENO 4 Burner stove/oven.  

 

The electronic ignitor  has stopped sparking.  

 

The battery is good.  I have cleaned around the ignitors on each burner on the stove and in the oven. I have checked for any obviously loose wires or connections. 

 

Can anyone give further troubleshooting advice for this.

 

Thanks and regards, Daniel Carlson on sv BeBe, SM#387

 

 

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.