SM Chain Counter Wiring


Thomas Peacock
 

I am still trying to get my factory installed (SM #240) chain counter working. The old sensor by the windlass was indeed shorted out; I had to replace with a unit identical except for the fact that the old sensor was normally on, and the new sensor is normally off. I have managed to switch that configuration by inserting a relay in the circuit. 
Despite this, the counter is not yet working. The display unit in the cockpit does light up at "00", but I can't seem to get it to count. In sussing out the wiring, I opened up the junction box above the galley and looked at the connections. 
There are basically four cables: one for power (two wires), one that goes forward to the windlass (three wires), one that goes to the cockpit windlass controls (three wires), and one to the display. (four tiny wires) 
The display has four tiny wires: red, black, green, and blue. The red supplies power, the black is ground, and the green connects with the green wire coming back from the windlass that I believe is the "signal wire", that changes as the windlass rotates. What seems unusual is that the tiny green wire energizes the forward wire, regardless other input, all the time. My sense is that the entire green circuit should be without voltage unless the sensor sends a current. I am concerned that there might be short or other problem that is causing the tiny green wire from the display to carry current. 
I know this is an esoteric question, but if anyone has any feedback I would greatly appreciate it.

Thanks as always,
Tom Peacock
SM #240 Aletes
Chesapeake Bay

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.