Re: 𝗭𝗒𝗒𝗠 π—΄π—²π˜ π˜π—Όπ—΄π—²π˜π—΅π—²π—Ώ

Arlo
 

Hello all. Just make sure that you use the latest version of Zoom. There are a number of significant security vulnerabilities associated with the zoom application.Β 

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.