Re: YANMAR 4JH3-HTE Diesel Engine RPMs drop and then it quits


Michael & Robyn
 
Edited

Thank y'all for the suggestions and the link.
This morning I rechecked the probe I took from the engine fuel filter. It was sitting overnight in a small glass jar with a sealed lid.
In daylight I was able to spot a ~3mm diameter water bubble at the bottom of the jar.
I took probes from both RACOR filters. The unused one was clean and no water. The other one had a bit of dirt and added a few more very small water bubbles to my jar.

Bill,
you asked why I didn't switch to the other RACOR filter.
First the filter didn't look dirty from outside shining a flash light against it. Second the pressure gauge was showing no significant low pressure.
And in case of dirt in the fuel I wanted to keep the second filter as my last reserve for a docking under engine maneuver.

We ran the Onan Gen-set last night again for an hour.
Today I did bleed the fuel with the manual pump again. Cleaned the air intake filter, which did not really show significant dirt.

I started the engine and it would run for a few seconds without load except the alternator. I tried several times. It would start at the second attempt and run for 10 to 20s and then drop RPMs. Putting the throttle forward made the engine speed up. But it would not last and die. One could hear that it was running on one or two cylinders.
I ran the Gen again for an hour to keep batteries charged. Then a few more attempts. When the RPMs where dropping I put throttle forward.
Finally I succeeded trying to keep it at 1500 RPMs. After 10 to 15 min it sometimes speed up to 1625 ... 1650 RPMs.
After 30 min it run constant at 1650 with the initial throttle setting that gave 1500 RPMs. One could occasionally hear a missed ignition. After a total of 45 min the engine ran fine still at 1650 RPM. Since batteries where charged to 90% I reduced to idle for a few min and the engine ran smooth at 850 RPM until I shut off.
We will see how it behaves tomorrow.

I observed a small puddle of diesel fuel at the rim of the manual pump which I had hit by accident diving for probing the RACOR filters.
My current assumption is that I have a small air leak in the fuel lines, maybe the manual pump itself. Or the air was introduced when the mechanic checked the RACOR filters.

To Giovannis point,
I had pushed the manual prime pump to help the engine start.

Will send an update tomorrow how it went.

Thank you and kind regards

--
Michael & Robyn

SY RIPPLE SM2K # 417
still anchored south of FIsherman's Island near Cape Charles entrance to Chesapeake Bay

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.