Re: Masse negative leak


ngtnewington Newington
 

Thanks Bill,

Alas it is not the Macerators. I hate working in the space for the main battery on/off as it is so easy to short out the positive to negative with a ratchet handle... maybe I can cover the positive with plastic sheet or something...
Nick 
Stern to in Finikas Syros waiting for the Meltemi to ease just a tad...
Amelia AML54-019


On 22 Jul 2020, at 00:43, CW Bill Rouse <brouse@...> wrote:


Ofer & Nick,

Remember, the minus Masse Light means there is a connection between 24-volts negative to the Amel bonding system. The most common issue is a Jabsco Macerator pump that has developed a leak at the seal, causing a connection to the Amel Bonding. Start by disconnecting the green/yellow wire from each macerator pump. If the light no longer comes ON, you have found it. Replace that macerator pump and reconnect the green/yellow wires.

If it was not the macerator pump and the light is ON for the (-) side, it is more difficult because the individual 24-volt breakers only turn OFF the positive side (+). For a negative side (-) Masse fault, you will need to disconnect the negative wires from the negative main battery switch. On most Amels, this is the lower switch. When the light goes out, you have narrowed your search to one main circuit.

If the (+) side is ON, try turning OFF each breaker throughout the boat one at a time. Don't forget breakers for the windlass, winches, and breakers in the engine room. Do this with all breakers.

I hope this helps you.

CW Bill Rouse Amel Owners Yacht School
Address: 720 Winnie, Galveston Island, Texas 77550 
View My Training Calendar


On Tue, Jul 21, 2020 at 12:32 PM ofer magen <ofermagen@...> wrote:
Hi Nick,
We had the same problem.
It took long time to solve , because the light was not always ON.

The way to find where  a bad contact between the minus and the grounding system is, is to start from the main switches near the batteries, disconnect each of the cables while checking the light. Ones you find a cable that if  disconnected the is OFF, look for the equipment down the cable and check the contacts and put corrosion x.
We found the problem in the forward locker . We had a leak of water from the new Bad! installed windlass rubber deck switches that created humidity on all electrical motors in the locker.

Good luck with the challenge.
You can call me if you want more info.



Ofer Magen
A 54 160 2010
Cyprus.
+972528795540

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.