Re: Onan shuts down under load without shutdown codes


Thomas Peacock
 

Hi Mark,

I was actually going to suggest that you look at the exhaust manifold, but didn’t want to look dumb. However, our problem wasn’t that it would shut down, but that it would not start. Many $$$ later, a good mechanic looked there and found the culprit.

In addition, I would have thought that the exhaust temperature would have risen and tripped the generator; but not all Onans are the same, I don’t think we have an exhaust temperature monitor, just a water temp.

I should add that the exhaust manifold carbon buildup is a common problem; it results from the generator being run at relatively low power demand levels, never at high enough fuel consumption (the RPM are constant) to burn out the carbon.

Everyone who has an Onan should be aware of this, and keep an eye on the build-up.  Ours was so far gone that we had to replace the manifold, cleaning was not an option.

Tom Peacock
SM 240 Aletes
Chesapeake Bay

On Aug 21, 2020, at 5:48 PM, Mark Pitt <mark_pitt@...> wrote:

 After replacing the thermostat, water sensor, fan belt, coolant, and raw water pump, it turns out the problem was carbon buildup in the exhaust manifold.  That’s been cleaned out and a new exhaust elbow added and all seems good now.  Thanks to all for their suggestions.

Mark Pitt
Sabbatical III,SM#419
Nantucket


--
Tom Peacock
SM 240 Aletes
Chesapeake Bay

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.