Re: Bilge pump


Paul Dowd and Sharon Brown
 

Alex,

 

I have had this happen twice to the auto bilge pump when the hose drained whilst in the yard for an extended stay. The resolution was to allow the hose to fill with water from the fridges by temporarily closing the seacock. Once the pump was primed as such it worked fine. I do keep a spare rubber flap for the pump but have not needed to replace it yet.

 

Cheers,

Paul

S/Y Ya Fohi - Amel 54 #98 - Grenada

 

From: main@AmelYachtOwners.groups.io <main@AmelYachtOwners.groups.io> On Behalf Of Alexis LETELLIER
Sent: 31 August 2020 09:52
To: main@AmelYachtOwners.groups.io
Subject: [AmelYachtOwners] Bilge pump

 

Hi all,
a bilge pump question on SM8 as our pump has been showing signs of weakness twice in one month. It keeps on pumping but nothing comes out. I've dismounted it but nothing looked wrong or obstructed. Then it worked again for 3 weeks, then failed again. I suspect an air leak, as the pump gasket looks a bit worn. Unfortunately, the safety manual pump doesn't work either.
So, if I have to change this pump, my questions are :
- do you recommend any upgrade or any model? (this one is a 25lt/min // A:4,5 // Rpm:25 // W90 // Serv. S2 // IP22 // I.CI.B// from 2012)
- I've seen an interesting set-up in a Contest Yacht with 2 bilge pumps (in a row?), so that you still have an electric one on if the first one has problems. Have you install this kind of set-up?
- about the manual safety pump, any idea what can be the problem? (i think it has quite never been used, and it may be dry and with an air leak as as well?)
Thank you !
Regards,
Alex


--
Cheers
Paul
Ya Fohi - Amel 54 #98

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.