Re: Port side Front Navigation Light unreliable


Ken Powers SV Aquarius
 

I also had a problem with the Bow Navigation Lights.  I replaced the bulb several times, and then bit the bullet and replaced the wire and installed the 2NM Hella LED set.  All mistakes.
There is a link to the 2NM LED set from Hella, and the 3NM Port light below.

Don't waist your time trying to keep the old bulbs on the bow, they don't last.  

Don't waist your time replacing the bow lights with ANY LIGHT which will have a splice near the front of the bow.  I replaced the 2NM Hella LED set twice now.

So, what to do:
Purchase the Hella Marine 3NM lights with a 3M cable.  Route the cables through the pulpit and splice inside the Port bow lazaretto to the boat cables.  If you have a SM any cable in the front of the boat is now worthless.  If you splice the cable where the sun and salt water can contact the area of the splice it will work GREAT... for about 9 months if you do a really good job.  Then you're back fixing it again.  



Don't buy these:
https://boatsupply.com/hella-marine-naviled-port-starboard-pair-2nm-colored-lens-white-housing/

Do buy these with 3M cable attached and splice in the Port Locker.
https://boatsupply.com/hella-marine-naviled-pro-port-navigation-lamp-3nm-red-lens-white-housing/

I already have the lights aboard Aquarius, just waiting for the second set of 2NM Hella lights to go bad, and then I will change to the 3NM with the 3M attached cables.

Aquarius
SM2K#262
Currently in Thailand on the hard.

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.