Re: Any SM owners use a Beta engine??


Dan Wilcox
 

Hi Mark, 

I did end up moving the motor mounts.  The ones closest to the "C" drive remained basically in the same place.  Center pin is approximately 2" aft of "C" drive body.  Both sets of new mounts are centered 18.25 inches apart.  The aft (towards stern) are 39" back (on center).  Forward I used the HY150, for the aft I went to the HY230 (This takes bulk of weight from engine and 24v alternator).

Note:  I did this install myself and in no way consider myself an expert.  There is a slight vibration when idling in neutral, but smooths out completely when placed in forward or reverse.  I'm guessing that is normal.

Thanks Dan
Feierabend SM #86

On Wednesday, January 20, 2021, 09:16:59 AM PST, Dan Wilcox via groups.io <dwilcox123@...> wrote:


i can take some pictures and measurements for you, and will also include mount models.  I'll run down to the boat today and send them tonight.

Thanks, Dan
Feierabend SM #86

On Wednesday, January 20, 2021, 05:19:30 AM PST, Mark Barter <markbarter100@...> wrote:


Hi Dan,

Sorry to resurrect this old topic but the installation didn't go well because the fitter failed to install new engine mounts meaning that we have excessive vibration and noise. I am going to have the mounts changed. 

What mounts did you end up using please? I can see they are different to the originals. Were you able to put them in the same place as the old mounts without alteration?

Thanks
Mark
--
Mark & Nicky Barter
S/V Nunky
SM 110

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.