Re: AC not cooling


 

Joerg,

You just brought up one of the continuing issues with some 55 owners. I have tried to learn as much as I can about the Climma Chiller System and maybe I can offer a few things that you have not considered. Please let me know because I am still learning.

The Climma Chiller system on most A55s is both efficient and complicated. Finding a qualified and experienced technician for the Climma Chiller system will be a challenge. I believe that the most common issues in order of probability are:
  1. The freshwater circuit pressure is not between 1.5 and 2.0 BAR
  2. There is air in the freshwater circuit.
  3. The liquid inside the freshwater circuit is not the correct mixture of 80% water and 20% antifreeze (Coolant) (Glicole) (Glycol)
  4. The heat exchange is not working efficiently because of poor saltwater flow caused by restrictions in that circuit.
  5. The sealed system & compressor are not working properly because of low refrigerant. This is the least probable cause, but regrettably, the first thing many technicians do is add refrigerant!
When adding to the freshwater circuit and increasing the pressure to 1.5 BAR it is VERY important to bleed all air. Climma states that "each single “top” point in the circuit has to have an air outlet valve. Avoid siphons and avoid slopes in the freshwater circuit and each fan coil must have an air outlet valve."  These are used to bleed air.

Climma's instructions on removing are:
"The air must be completely removed from all the access points of the circuit (collectors, fan coils, and all the other system components) starting from the lowest point and maintaining the pressure at 1,5 Bar. This must be done without [running] the pump. Continue to remove air from each single access point of the freshwater circuit until no air exits anymore, always maintaining the pressure at 1,5 Bar."  Comment: I believe that when removing air, if the pressure drops, you will have to stop the bleed process, turn on the pump and potentially add more fluid until the pressure again increases to 1.5 BAR, then start the bleeding process over again at the lowest point.

Climma's instructions continue: "Start the system (compressor) in COOL mode. Both the pumps (sea and freshwater Leave the freshwater pump working for 30 seconds, then shut down the system completely again and start with the previous procedure to remove air from each access point to the fresh water
at 1,5 Bar. Air removal is complete when no more air exits from the access points and the freshwater pump works with no problem and with no noise." 
Comment: I take this to mean that the process of removing all air will take at least 2 attempts.

Climma also states, "We strongly advise installing in the freshwater circuit a Deaerator, right after the pump water exit. The Deaerator will reduce almost to zero the need of removing air from the circuit. Deaerators are available in different sizes depending on the size of the freshwater circuit."

I am not absolutely positive of this, but I believe that Amel did not install a Deaerator. I have not seen one on an Amel with a Climma Chiller System, and incidentally, there are none offered by Veco on their website. Most of the 55 owners I know have an issue with low levels in the freshwater system and I believe have further complications with air and the insufficient process of bleeding air. 

It seems to me that this suggested Deaerator should be investigated further.

Here are some examples of a DEARATOR:
image.png
image.png


Bill
CW Bill Rouse Amel Owners Yacht School
Address: 720 Winnie, Galveston Island, Texas 77550 
View My Training Calendar


On Sat, Jun 12, 2021 at 8:00 AM Joerg Esdorn via groups.io <jhe1313=yahoo.com@groups.io> wrote:
After 2 years, I am trying to get the Climma working again.  Both the saltwater and the circulation pump started up fine but I needed to fill up the circulation cycle a little bit to get to the required 1.5 bar.  The compressor starts up fine as well.  But while the temperature of the coolant decreases initially by a few degrees, it then stalls and increases again.  I suspect I have a coolant leak but I wonder whether there are alternatives to calling the service man to fill it up.  Any ideas?

Many thanks! 

Joerg Esdorn
A55 #53 Kincsem
In very hot Vigo, Spain

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.