Re: [Amel] SM 24v Bilge Pump


Chris Smither <yachtakwaaba@...>
 

Richard,
 If it is any help, attached is the exploded diagram of the PAM pump with the manufacturers details. Mine has been on my Santorin for 20 years, and is getting close to it's "sell by" date.
As an aside, I have found that truck tyre inner tubes make perfect diaphragm's if you have a problem miles from anywhere.

Mike
Santorin, Akwaaba 1990

--- On Sun, 11/7/10, Richard Piller <richard03801@...> wrote:

From: Richard Piller <richard03801@...>
Subject: Re: [Amel] SM 24v Bilge Pump
To: amelyachtowners@...
Date: Sunday, November 7, 2010, 4:05 PM







 









Kent, after our first pump failed we found a Vetus pump to replace other

original diaphragm pump. After two more failures it seems there are some

"issues" with that pump. We in desperation installed a 24 volt macerator pump.

it has a 1.5" intake and one inch out put. So we installed a reducer on the

line going overboard. The macerator pump runs at well over 8 gallons per min.

by far faster and using less power then the previous pump (s). Second I can

hear it start up and run it may be not as Amel but I know when the bilge pump in

on and I kinda like that. It's worked well and draws without issue. For us it's

a very big improvement.

We spent a lot of money and time before we got to this point...

Good luck

Richard on SM 209 in Annapolis FOR SALE



________________________________

From: Kent Robertson <karkauai@...>

To: amelyachtowners@...

Sent: Sat, November 6, 2010 1:43:38 PM

Subject: [Amel] SM 24v Bilge Pump



Hi again, all,

I just got back on Kristy to do some prep for the trip south and discovered that

the bilge pump isn't working. The flapper valves on the intake and output sides

of the pump were attached to the inside of the pump head by screws that have

rusted completely off, making it impossible to replace with new ones. I think I

will need to get a new head for the pump but there are no identifying marks on

the pump except "PAM" printed on a sticker on the pump head. I believe this is

a Sandvik pump, but cant find it searching the web. Can anyone tell me what

brand and model pump it should be on SM243? Has anyone replaced this pump with

another brand and if so how much of a problem was it to mount in the engine

room? Has anyone had the same problem with this pump and do you have

suggestions for how to repair it?



Thanks as always for your replies.

Kent

SM243

KRISTY



[Non-text portions of this message have been removed]

Join main@AmelYachtOwners.groups.io to automatically receive all group messages.