Reya Bilge Pump not pumping


Mohammad Shirloo
 

Our Reya Bilge pump (TIPO - MARINA) has stopped pumping. A new kit was installed about a year ago and it has worked fine other than losing prime a few times. I would have to remove the hose and intake from the bilge, fill the hose with water while the pump was running and as soon as it would prime I would put it back in and it would work fine. In the past month, I have had to do this several times.


I remember reading on the forum that the problem can be with the pipe getting old and not sealing properly and letting air back in. So I disconnected the hose and filled it with water with the back flow intake attached. Water slowly drains from the back flow intake and nothing comes out from around the hose.


My questions are:

1. Is the backflow device 100% responsible for not letting the water drain out of the pump or does the pump need to be attached to the hose for the back flow device to work?


2. Since I could not get the pump to work even when the hose was held at pump height and filled with water, do you agree with my conclusion that the a new re-build kit needs to be installed?


3. I know I had seen the instructions for installing the re-build kit on this forum but can't seem to find it. Can some one point me in the right direction or e-mail me the procedure/manual at mshirloo at transpacific dot us.


Thank you


william_maffei@...
 

Hey there -

If you are constantly having to prime your pump then there is an air leak somewhere in the line that needs to be addressed. I had the same problem when I did the re-build. I am almost certain (if done correctly) it is not necessary to re-build again. To solve my problem I replaced the one way value on the intake hose and added a hose clamp at the bottom NPT on the pump itself. Worked like a charm. 

Bill Maffei
It's all Good
SM #195


Mohammad Shirloo
 

Hi Bill;

Thanks for the reply.

I also suspect the back flow intake. However wanted to be sure. Do you know if the backflow device should be able to hold the water in the hose with the pipe disconnected from the pump without any water leakage?

Also, where did you buy the back flow device from?

Thanks

Mohammad and Aty
Amel 54 #099
B&B Kokomo