Topics

[Amel Yacht Owners] Trouble Shooting an older TechPro Battery Charger.

Mohammad Shirloo
 

Hi Bill;
 
I cannot offer any useful hints on your actual issue as I am unfamiliar with your unit. However, when Olivier was surveying our 54 he mentioned that the two chargers should not be run simultaneously. I do not know if this has anything to do with your issue, but thought a good side note to keep in mind.
 
Mohammad and Aty
B&B Kokomo
Amel 54 #099
 


From: amelyachtowners@... [mailto:amelyachtowners@...]
Sent: Thursday, December 28, 2017 8:00 PM
To: amelyachtowners@...
Subject: [Amel Yacht Owners] Trouble Shooting an older TechPro Battery Charger.

 

Our battery charging system consists of a shiny new Victron Multiplus 24/3000/70 which works a treat, and a Techpro 50Amp charger which was part of the original install at the factory in 1996 and has done yeoman duty for 21 years.  We use both of them when running the genset to bulk charge the house batteries with 100+ amps.


Unfortunately the Techpro has stopped outputting charging current.


So far I have confirmed that there is both 220VAC and 24VDC at the circuit boards inside the charger. The battery charge status lights on the front panel are not lit. No obvious mechanical problems.  I haven't pulled the unit out yet, but there are no obvious internal circuit breakers or fuses.


Anybody have any experience/suggestions/hints on what to try next on one of these vintage units?


Bill Kinney

SM160, Harmonie

Key West, FL


Alan Leslie
 

Just my 2 cents worth.....
In the Amel manual on my boat it tells us to first turn on the 100A charger then after it has stabilised turn on the smaller charger (in our case 30A)...
I don't see what the problem would be running two chargers at the same time...we do that with our solar panels and wind generator..
Cheers
Alan
Elyse SM437