Topics

[Amel Yacht Owners] Re: Diaphragm Bilge Pump failure.

Jean-Pierre's MacBook Air <jgermain@...>
 

Hi Gang,

Like Gary, I’ve installed a diaphragm pump.  Mine is a Vetus unit and indeed, it does work well…

Jean-Pierre
Sy Eleuthera, SM 007, Panama



On 19 Jan 2018, at 04:09, gary@... [amelyachtowners] <amelyachtowners@...> wrote:


I have to say that at first I wasn't too impressed with the 'un-Amel' solution that was installed on Adagio when we got it, but after further review I believe it was a good decision on the part of the P.O.
The original pump has been replaced by a 24v Whale Gusher diaphragm mounted about a meter above the full water level. The hose from the pump run straight down into the sump and has check (standard joker) valves both before and after the pump to prevent loss of prime. I installed new jokers in Feb., 2014 and have not had a lick of trouble since. The pump is easily accessible, a rebuild kit is readily available (although I haven't had to rebuild it yet) and it's 'relatively' inexpensive. 

It probably isn't a fast to pump the bilge as the original one (takes a full minute or so) but it's quiet and I've kind of grown into liking it. Just my 2 cents worth on this kind of project.

Gary W.
SM 209 Adagio
Fethiye, Turkey





hanspeter baettig
 

Bonjour JP
I too bought a Vetus Pump Type EMP 140 as a spar part. My old pump from Amel, 25 years old is still working fine.
Questions:
How did you manage the problem from the already installed tubes, 30 mm (1 1/4 inch) old pump, 38 mm ( 1 1/2 inch) new Vetus pump ? Wich connector you used or you chanbe the old tubes to 38 mm ? 
How did you manage the fixation of the new pump ?
Can you send me pics about the installation , fixation ( you need new holes ). Many thanks for your reply.
You can send me the pics to: hanspeter dot baettig at bluemail dot ch

Salutations
HP
SM 16, Tamango 2
Las Palmas

----Ursprüngliche Nachricht----
Von : amelyachtowners@...
Datum : 19/01/2018 - 11:36 (MN)
An : amelyachtowners@...
Betreff : Re: [Amel Yacht Owners] Re: Diaphragm Bilge Pump failure.

 

Hi Gang,


Like Gary, I’ve installed a diaphragm pump.  Mine is a Vetus unit and indeed, it does work well…

Jean-Pierre
Sy Eleuthera, SM 007, Panama



On 19 Jan 2018, at 04:09, gary@... [amelyachtowners] <amelyachtowners@...> wrote:


I have to say that at first I wasn't too impressed with the 'un-Amel' solution that was installed on Adagio when we got it, but after further review I believe it was a good decision on the part of the P.O.
The original pump has been replaced by a 24v Whale Gusher diaphragm mounted about a meter above the full water level. The hose from the pump run straight down into the sump and has check (standard joker) valves both before and after the pump to prevent loss of prime. I installed new jokers in Feb., 2014 and have not had a lick of trouble since. The pump is easily accessible, a rebuild kit is readily available (although I haven't had to rebuild it yet) and it's 'relatively' inexpensive. 

It probably isn't a fast to pump the bilge as the original one (takes a full minute or so) but it's quiet and I've kind of grown into liking it. Just my 2 cents worth on this kind of project.

Gary W.
SM 209 Adagio
Fethiye, Turkey