Eno Stove Electronic Ignitor


Dan Carlson
 

Hello all,. I have the original ENO 4 Burner stove/oven.  

The electronic ignitor  has stopped sparking.  

The battery is good.  I have cleaned around the ignitors on each burner on the stove and in the oven. I have checked for any obviously loose wires or connections. 

Can anyone give further troubleshooting advice for this.

Thanks and regards, Daniel Carlson on sv BeBe, SM#387



Stephen Hancock
 

Contacts on the start switch needs cleaning maybe. Use multimeter to check continuity.

On Apr 15, 2019, at 11:56 AM, Dan Carlson <carlsdan61@...> wrote:

Hello all,. I have the original ENO 4 Burner stove/oven.  

The electronic ignitor  has stopped sparking.  

The battery is good.  I have cleaned around the ignitors on each burner on the stove and in the oven. I have checked for any obviously loose wires or connections. 

Can anyone give further troubleshooting advice for this.

Thanks and regards, Daniel Carlson on sv BeBe, SM#387




Dan Carlson
 

Thanks for the prompt Stephen,  that got me tearing into things a bit more.  Continuity thru the switch was good (infinate resistance when off, zero resistance when pressed), so that was not the problem. However, after I had reassembled the front panel, I then retested the voltage thru the switch at the point where the leads connect to the Igniter module at the back of the stove.  This was in fact less than 1 volt.  I had already checked the battery, and also the positive lead from the battery box to the Igniter module, but this was the first time testing the complete loop.   

 The reduced continuity was in the battery ensemble.  I put some dielectric grease on each end of the battery and also on the contact points on the spring at the cap.  This gave me 1.5 volts and the ignitor works again.

Thanks for the thoughtful reply. It gave me a new direction to pursue which eventually led me to the solution.

Best regards, Daniel Carlson on sv BeBe, SM# 387


On Mon, Apr 15, 2019, 11:50 AM Stephen Hancock via Groups.Io <sammie.whammie=yahoo.com@groups.io wrote:
Contacts on the start switch needs cleaning maybe. Use multimeter to check continuity.

On Apr 15, 2019, at 11:56 AM, Dan Carlson <carlsdan61@...> wrote:

Hello all,. I have the original ENO 4 Burner stove/oven.  

The electronic ignitor  has stopped sparking.  

The battery is good.  I have cleaned around the ignitors on each burner on the stove and in the oven. I have checked for any obviously loose wires or connections. 

Can anyone give further troubleshooting advice for this.

Thanks and regards, Daniel Carlson on sv BeBe, SM#387




 

Dan,

I think that you have a spare. When the first one died, I remember I bought 2. I also relocated it to behind the stove to be able to replace easily. Look behind the stove and find a spare that looks like it. I believe I found ignitors at https://www.espares.co.uk

Best,

Bill Rouse
720 Winnie St.
Galveston, Texas 77550
832-380-4970



On Mon, Apr 15, 2019 at 10:56 AM Dan Carlson <carlsdan61@...> wrote:
Hello all,. I have the original ENO 4 Burner stove/oven.  

The electronic ignitor  has stopped sparking.  

The battery is good.  I have cleaned around the ignitors on each burner on the stove and in the oven. I have checked for any obviously loose wires or connections. 

Can anyone give further troubleshooting advice for this.

Thanks and regards, Daniel Carlson on sv BeBe, SM#387



Dan Carlson
 

Thanks Bill,  It turns out that it was just poor contacts with the battery.   The battery was the first thing that I checked, and then I also tried to check the contact in the battery case, but it was in fact delivering too low of a voltage due to low contact.  Some dielectric grease on the ends of the battery solved the problem.   When I get back the boat I will take a look for the spare.   I saw all of your clear notations on the different wires, so I knew that you had done some trouble shooting in there at some time. 

 

Best regards,   Dan

 

From: main@AmelYachtOwners.groups.io <main@AmelYachtOwners.groups.io> On Behalf Of CW Bill Rouse
Sent: Monday, April 15, 2019 2:36 PM
To: main@amelyachtowners.groups.io
Subject: Re: [AmelYachtOwners] Eno Stove Electronic Ignitor

 

Dan,

 

I think that you have a spare. When the first one died, I remember I bought 2. I also relocated it to behind the stove to be able to replace easily. Look behind the stove and find a spare that looks like it. I believe I found ignitors at https://www.espares.co.uk

 

Best,

 

Bill Rouse

720 Winnie St.

Galveston, Texas 77550

832-380-4970

 

 

On Mon, Apr 15, 2019 at 10:56 AM Dan Carlson <carlsdan61@...> wrote:

Hello all,. I have the original ENO 4 Burner stove/oven.  

 

The electronic ignitor  has stopped sparking.  

 

The battery is good.  I have cleaned around the ignitors on each burner on the stove and in the oven. I have checked for any obviously loose wires or connections. 

 

Can anyone give further troubleshooting advice for this.

 

Thanks and regards, Daniel Carlson on sv BeBe, SM#387

 

 


 

Dan,

CorrosionX. Enough said.

Best,

Bill Rouse
720 Winnie St.
Galveston, Texas 77550
832-380-4970



On Mon, Apr 15, 2019 at 5:18 PM Dan Carlson <carlsdan61@...> wrote:

Thanks Bill,  It turns out that it was just poor contacts with the battery.   The battery was the first thing that I checked, and then I also tried to check the contact in the battery case, but it was in fact delivering too low of a voltage due to low contact.  Some dielectric grease on the ends of the battery solved the problem.   When I get back the boat I will take a look for the spare.   I saw all of your clear notations on the different wires, so I knew that you had done some trouble shooting in there at some time. 

 

Best regards,   Dan

 

From: main@AmelYachtOwners.groups.io <main@AmelYachtOwners.groups.io> On Behalf Of CW Bill Rouse
Sent: Monday, April 15, 2019 2:36 PM
To: main@amelyachtowners.groups.io
Subject: Re: [AmelYachtOwners] Eno Stove Electronic Ignitor

 

Dan,

 

I think that you have a spare. When the first one died, I remember I bought 2. I also relocated it to behind the stove to be able to replace easily. Look behind the stove and find a spare that looks like it. I believe I found ignitors at https://www.espares.co.uk

 

Best,

 

Bill Rouse

720 Winnie St.

Galveston, Texas 77550

832-380-4970

 

 

On Mon, Apr 15, 2019 at 10:56 AM Dan Carlson <carlsdan61@...> wrote:

Hello all,. I have the original ENO 4 Burner stove/oven.  

 

The electronic ignitor  has stopped sparking.  

 

The battery is good.  I have cleaned around the ignitors on each burner on the stove and in the oven. I have checked for any obviously loose wires or connections. 

 

Can anyone give further troubleshooting advice for this.

 

Thanks and regards, Daniel Carlson on sv BeBe, SM#387

 

 


Gregory Dmitriev
 

Yes. Battery connection is the often problem.
I’ve experienced the same and changed the compartment.