TV lift quitted working


luvkante
 

Dear Amelians,

my TV lift in the salon quitted working. No reaction on the up/down button. 
Any experiences with this problem like corrosions, fuses, motors? Any hints what to check?

Best,

Martin

AMEL54 #149 „CHIARA“ 


 

I assume this option was installed by Amel. 

Yes, check all of those as well as the remote batteries.

Also, the salon TV actuator has a small metal control box containing four fuses. In the salon, this is located behind the seating and visible after removing a wood panel. 

I do not know where this is located in the aft berth. Find it and check the fuses.


Bill


CW Bill Rouse Amel Owners Yacht School
720 Winnie, Galveston Island, Texas 77550 
   

On Thu, Jun 23, 2022 at 6:04 AM luvkante via groups.io <luvkante=yahoo.com@groups.io> wrote:

Dear Amelians,

my TV lift in the salon quitted working. No reaction on the up/down button. 
Any experiences with this problem like corrosions, fuses, motors? Any hints what to check?

Best,

Martin

AMEL54 #149 „CHIARA“ 


Doug Smith
 

There is a fuse inside the control box. You remove the cover and it is right there. If the fuse is good, then you should see the internal relays making contact when you push the buttons up or down. If those are actuating then, it is the actual lifting mechanism. I had some gear internal to the lift actuator that broke and had to replace that lifter. Found it on eBay for $80. 

Thanks, Doug Smith

Amel 54-113, Aventura
Hilton Head SC
Dugsmith98@...

On Jun 23, 2022, at 7:03 AM, luvkante via groups.io <luvkante@...> wrote:



Dear Amelians,

my TV lift in the salon quitted working. No reaction on the up/down button. 
Any experiences with this problem like corrosions, fuses, motors? Any hints what to check?

Best,

Martin

AMEL54 #149 „CHIARA“ 


Roque
 

Hi Martin

It is a Linak Lifting Column (High-speed lifting columns for height-adjustable desks (linak.com)). Maybe they can help you out.

On A54 #117 it is model DL4(DL4001B00675560) that probably was discontinued. Perhaps replaced by the one attached

Usually, the problem is what they call the "control box". A new one will have to be set up to work with the old lifting model. It costs around 400 Euros.

Roque

Attika A54 117
Paraty -Brazil
.

--
Roque
Attika A54 117
Paraty - Brazil 


luvkante
 

Thank you so much Roque. 


luvkante
 

Yes Bill, installed by AMEL. Thank you very much, will check. 


Gesendet von Yahoo Mail für iPhone

Am Donnerstag, Juni 23, 2022, 3:06 PM schrieb CW Bill Rouse <brouse@...>:

I assume this option was installed by Amel. 

Yes, check all of those as well as the remote batteries.

Also, the salon TV actuator has a small metal control box containing four fuses. In the salon, this is located behind the seating and visible after removing a wood panel. 

I do not know where this is located in the aft berth. Find it and check the fuses.


Bill


CW Bill Rouse Amel Owners Yacht School
720 Winnie, Galveston Island, Texas 77550 
   

On Thu, Jun 23, 2022 at 6:04 AM luvkante via groups.io <luvkante=yahoo.com@groups.io> wrote:

Dear Amelians,

my TV lift in the salon quitted working. No reaction on the up/down button. 
Any experiences with this problem like corrosions, fuses, motors? Any hints what to check?

Best,

Martin

AMEL54 #149 „CHIARA“ 


luvkante
 

Great, Doug. Will follow your precise instructions. 


Gesendet von Yahoo Mail für iPhone

Am Donnerstag, Juni 23, 2022, 3:54 PM schrieb Doug Smith via groups.io <dugsmith98@...>:

There is a fuse inside the control box. You remove the cover and it is right there. If the fuse is good, then you should see the internal relays making contact when you push the buttons up or down. If those are actuating then, it is the actual lifting mechanism. I had some gear internal to the lift actuator that broke and had to replace that lifter. Found it on eBay for $80. 

Thanks, Doug Smith

Amel 54-113, Aventura
Hilton Head SC
Dugsmith98@...

On Jun 23, 2022, at 7:03 AM, luvkante via groups.io <luvkante@...> wrote:



Dear Amelians,

my TV lift in the salon quitted working. No reaction on the up/down button. 
Any experiences with this problem like corrosions, fuses, motors? Any hints what to check?

Best,

Martin

AMEL54 #149 „CHIARA“